summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2023-05-07 13:38:18 +0700
committerKonstantin Shalygin2023-05-07 13:38:18 +0700
commitc37e612c34d37fc20f567402acc9eafb8c8ab082 (patch)
treeac0441e702582e652a33fa1cb3ae5f014ac44a25 /PKGBUILD
parentf2e7f375da1d6fcd7a9f033a5acac7cdf154f5f3 (diff)
downloadaur-c37e612c34d37fc20f567402acc9eafb8c8ab082.tar.gz
Remove py2 version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13114c3981aa..0db4e910b05f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,19 @@
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgbase='pyocclient'
-pkgname=('python-pyocclient' 'python2-pyocclient')
+pkgname='python-pyocclient'
pkgver='0.6'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Python client library for ownCloud'
arch=('any')
url="https://github.com/owncloud/${pkgbase}"
-makedepends=('python' 'python-setuptools'
- 'python2' 'python2-setuptools')
+depends=('python' 'python-requests' 'python-six')
+makedepends=('python' 'python-setuptools')
license=('MIT')
source=("${url}/archive/v${pkgver}.tar.gz")
sha256sums=('ec524bbabecd2ba00315f6517dc0628bb2c8c32d644a3c5dfc2f1e7d61eb65b4')
-package_python-pyocclient() {
- depends=('python' 'python-requests' 'python-six')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
+package() {
+ cd "${pkgbase}-${pkgver}"
python setup.py install -O1 --root="${pkgdir}"
}
-
-package_python2-pyocclient() {
- depends=('python2' 'python2-requests' 'python2-six')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
- python2 setup.py install -O1 --root="${pkgdir}"
-}