summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryjun2021-10-01 16:30:04 +0800
committeryjun2021-10-01 16:30:04 +0800
commit92e6212394190b8f9da051fed3c92ea408ceab6e (patch)
tree0099ced8f7cd527ebbac55fa1bdf9c4068f2b2df /PKGBUILD
parent18e5f0584bce198d9396c83fdfa2ba08b9518b2d (diff)
downloadaur-92e6212394190b8f9da051fed3c92ea408ceab6e.tar.gz
PKGBUILD: fixed missing depeneds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 279f5f62f75c..622686734a31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,28 @@
pkgname=pyocd-git
_pkgname=pyOCD
-pkgver=v0.31.0.r1.ga064d8fb
+pkgver=v0.32.0.r4.g37c44ea1
pkgrel=1
pkgdesc="Python On Chip Debugger and programmer for ARM Cortex-M microcontrollers using CMSIS-DAP"
arch=('any')
url="https://github.com/pyocd/pyOCD"
license=('Apache')
-depends=('python'
+depends=('python-capstone'
'python-cmsis-pack-manager'
'python-colorama'
'python-intelhex'
'python-intervaltree'
'python-naturalsort'
'python-prettytable'
- 'python-pyaml'
'python-pyelftools'
+ 'pylink'
+ 'pyocd-pemicro'
'python-pyusb'
- 'python-setuptools'
+ 'python-pyaml'
'python-six'
- 'pylink'
)
-makedepends=("git")
+makedepends=('git'
+ 'python-setuptools')
provides=('pyocd')
conflicts=('pyocd')
source=("git+${url}")