summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSimone Riva2015-06-08 18:17:09 +0200
committerSimone Riva2015-06-08 18:17:09 +0200
commit3ff345202f0a18a3fa3af0f1fce8e014bd4aeefa (patch)
tree353e581f4935bdf2553824e61a0f0780191a53c9 /PKGBUILD
downloadaur-3ff345202f0a18a3fa3af0f1fce8e014bd4aeefa.tar.gz
aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded055576daa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+pkgname=pyparticles
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="Particles simulation toolbox for python, with some force model and integrations methods"
+arch=(any)
+license=('GPL3')
+url="http://pyparticles.wordpress.com/"
+depends=('python2' 'python2-opengl' 'python2-scipy' 'python2-numpy' 'python2-matplotlib' )
+
+
+source=("http://sourceforge.net/projects/pyparticles/files/PyParticles-${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('89f207b23449f33ca7ece9533d4571ad440fcd91')
+
+build() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ echo ${pkgdir}
+ python2 setup.py install --root=${pkgdir} --prefix=usr --optimize=1
+}