diff options
author | fdev31 | 2024-05-12 19:20:47 +0200 |
---|---|---|
committer | fdev31 | 2024-05-12 19:20:47 +0200 |
commit | 96aba88e8ef7c55fd37b6d4ba6a35880365ea530 (patch) | |
tree | e452d2b04c510a329aae5ec2db9be6cc31f65d9d /PKGBUILD | |
parent | 44c75cc661283d5f11ba6c766558199f83c5af71 (diff) | |
download | aur-96aba88e8ef7c55fd37b6d4ba6a35880365ea530.tar.gz |
simplify release PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 22 |
1 files changed, 8 insertions, 14 deletions
@@ -2,38 +2,32 @@ # Contributor: Fabien Devaux <fdev31@gmail.com> pkgname=pyprland pkgver=2.2.20 -pkgrel=1 +pkgrel=2 pkgdesc="Customize your Hyprland with scratchpads, menus, easy monitor layout and other extensions" arch=(any) url="https://github.com/fdev31/pyprland" license=('MIT') groups=() -depends=('python' 'python-aiofiles') -makedepends=('git' 'python-build' 'python-installer' 'python-poetry') +depends=('python' 'python-aiofiles' 'hyprland') +makedepends=('python-build' 'python-installer' 'python-poetry') provides=("${pkgname}") conflicts=("${pkgname}") replaces=() backup=() options=() -install= -source=(git+"https://github.com/fdev31/pyprland.git#tag=${pkgver}") noextract=() -md5sums=('SKIP') - -pkgver() { - cd "$srcdir/${pkgname%-git}" - git checkout ${pkgver} - printf "%s" "$(git describe --tags)" -} +source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/${pkgver}.tar.gz") +sha256sums=('76e71dd7da5cb5e3b3fd5d6ef8375f5eb4588f07a3c488813c0bf0b72c624ea5') build() { - cd "$srcdir/${pkgname%-git}" + cd $pkgname-$pkgver python -m build --wheel --no-isolation } package() { - cd "$srcdir/${pkgname%-git}" + cd $pkgname-$pkgver python -m installer --destdir="$pkgdir" dist/*.whl install -Dm0644 "scripts/completions/pypr.bash" "$pkgdir/usr/share/bash-completion/completions/pypr" install -Dm0644 "scripts/completions/pypr.zsh" "$pkgdir/usr/share/zsh/site-functions/_pypr" + install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" } |