summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLingMan2021-01-25 01:45:11 +0100
committerLingMan2021-01-25 01:54:26 +0100
commit926aff2c43fc2dc3d1dc359f97e6b0f8925e2748 (patch)
tree22fc66d5f4b4efe6e1d92f159c64fcd4227709eb /PKGBUILD
parentf7dc692ce87b6598f131b619c494ae071a847620 (diff)
downloadaur-926aff2c43fc2dc3d1dc359f97e6b0f8925e2748.tar.gz
* build dependency 'sip' is now called 'sip4'
* drop unnecessary runtime dependency on 'sip'/'sip4' * buzo stepped down as maintainer, credit him as contributor * update project url to use https * update sourceforge download url format
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d25a0caa4374..435c6f3e8114 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: Stephan Springer <buzo+arch@Lini.de>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
@@ -7,13 +7,13 @@
pkgbase=pyqt4
pkgname=('pyqt4-common' 'python-pyqt4' 'python2-pyqt4')
pkgver=4.12.3
-pkgrel=4
+pkgrel=5
arch=('x86_64')
-url='http://www.riverbankcomputing.com/software/pyqt/intro'
+url='https://riverbankcomputing.com/software/pyqt/intro'
license=('GPL')
-makedepends=('sip' 'python-sip-pyqt4' 'python2-sip-pyqt4' 'python-dbus' 'phonon-qt4'
+makedepends=('sip4' 'python-sip-pyqt4' 'python2-sip-pyqt4' 'python-dbus' 'phonon-qt4'
'mesa' 'python2-opengl' 'python2-dbus')
-source=("http://downloads.sourceforge.net/pyqt/PyQt4_gpl_x11-${pkgver}.tar.gz")
+source=("https://downloads.sourceforge.net/project/pyqt/PyQt4/PyQt-${pkgver}/PyQt4_gpl_x11-${pkgver}.tar.gz")
sha256sums=('a00f5abef240a7b5852b7924fa5fdf5174569525dc076cd368a566619e56d472')
prepare() {
@@ -65,7 +65,7 @@ package_pyqt4-common() {
package_python-pyqt4() {
pkgdesc="A set of Python 3.x bindings for the Qt toolkit"
- depends=('sip' 'python-sip-pyqt4' 'python-dbus' 'pyqt4-common')
+ depends=('python-sip-pyqt4' 'python-dbus' 'pyqt4-common')
optdepends=('phonon-qt4: enable audio and video in PyQt applications')
replaces=('pyqt')
conflicts=('pyqt')
@@ -82,7 +82,7 @@ package_python-pyqt4() {
package_python2-pyqt4() {
pkgdesc="A set of Python 2.x bindings for the Qt toolkit"
- depends=('sip' 'python2-sip-pyqt4' 'python2-dbus' 'pyqt4-common')
+ depends=('python2-sip-pyqt4' 'python2-dbus' 'pyqt4-common')
optdepends=('phonon-qt4: enable audio and video in PyQt applications'
'python2-opengl: enable OpenGL 3D graphics in PyQt applications')
replaces=('python2-pyqt')