summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122018-12-05 11:05:00 +0100
committerwillemw122018-12-05 11:05:00 +0100
commit5c6f9a743a460a12d1de56e95f1a868c030f1063 (patch)
tree2e9cc4cdede957453434103a4b481236d012c293 /PKGBUILD
parent0bc64d42529a4a6e1926cafc18dfd85ff001b66b (diff)
downloadaur-5c6f9a743a460a12d1de56e95f1a868c030f1063.tar.gz
Update PKGBUILD (provided by sng) and remove man page file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a63df23679af..e1d7bceec108 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: willemw <willemw12@gmail.com>
-# Contributor: sng
+# Contributor: sng <sng at hellug dot gr>
# Contributor: aksr <aksr at t-com dot me>
_pkgname=pyradio
pkgname=$_pkgname-git
-pkgver=0.4.r142.g882da1e
+pkgver=0.6.0.r0.gd13b7e3
pkgrel=1
pkgdesc="Command line internet radio player"
arch=('any')
@@ -15,10 +15,8 @@ optdepends=('mplayer: as backend' 'vlc: as backend' 'mpv: as backend' 'socat: if
makedepends=('git' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
-source=($pkgname::git://github.com/coderholic/pyradio.git
- pyradio.1)
-md5sums=('SKIP'
- '53460ef86b415aca61eba663ecc4240e')
+source=($pkgname::git://github.com/coderholic/pyradio.git)
+md5sums=('SKIP')
pkgver() {
cd $pkgname
@@ -26,12 +24,18 @@ pkgver() {
}
package() {
- install -Dm644 pyradio.1 "$pkgdir/usr/share/man/man1/pyradio.1"
-
cd $pkgname
+ descr="$(git describe --long --tags)"
+ sed -i "s/git_description = ''/git_description = '$descr'/" pyradio/radio.py
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/pyradio/README.md"
- install -Dm644 pyradio/stations.csv "$pkgdir/usr/share/doc/pyradio/stations.csv"
-}
+ install -Dm644 README.html "$pkgdir/usr/share/doc/pyradio/README.html"
+ install -Dm644 build.md "$pkgdir/usr/share/doc/pyradio/build.md"
+ install -Dm644 build.html "$pkgdir/usr/share/doc/pyradio/build.html"
+ gzip pyradio.1
+ install -Dm644 pyradio.1.gz "$pkgdir/usr/share/man/man1/pyradio.1.gz"
+ # We don't have to install stations.csv, it is already in the egg file
+ #install -Dm644 pyradio/stations.csv "$pkgdir/usr/share/doc/pyradio/stations.csv"
+}