summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2023-01-05 09:09:23 +0000
committerAntonio Rojas2023-01-05 09:09:23 +0000
commit961d773595ac6abd1cf645d011ab9e5a09556ea3 (patch)
tree56d9a72a1536dfbd90d0672ddff4312306fdc165 /PKGBUILD
parent76708f955556edb2baa1c67289c5b3c50e4dff58 (diff)
downloadaur-961d773595ac6abd1cf645d011ab9e5a09556ea3.tar.gz
Don't use limited API
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 589d30346703..3382c3655673 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgname=(shiboken2 python-shiboken2 pyside2 pyside2-tools)
_qtver=5.15.8
_clangver=14.0.6
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://www.qt.io'
license=(LGPL)
@@ -31,12 +31,15 @@ optdepends=('qt5-svg: QtSvg bindings'
'qt5-quickcontrols2: QtQuickControls2 bindings')
_pkgfqn=pyside-setup-opensource-src-$_qtver
source=(https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz
- fix-build.patch)
+ fix-build.patch
+ limited-api.patch)
sha256sums=('23436302c8deb5b4cbc769b205d09604e38ba83b40708efccb7bd8c9af6f6b5d'
- '4f8815840b5df2e1e3b9f201a3402126821b0d9702920cefdc18050639143ad1')
+ '4f8815840b5df2e1e3b9f201a3402126821b0d9702920cefdc18050639143ad1'
+ '433b4fa26203ecabf6ac7d4288467a918a4fba91ef885b0a11c466aae99050cd')
prepare() {
patch -d $_pkgfqn -p1 < fix-build.patch
+ patch -d $_pkgfqn -p1 < limited-api.patch
}
build() {