summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEvangelos Foutras2021-12-01 13:44:48 +0000
committerEvangelos Foutras2021-12-01 13:44:48 +0000
commitd60e6aeb3844aa8f6e79e36c4293cc25be9e0f51 (patch)
tree242433073ff96134228e2448eecbedcf64ba277b /PKGBUILD
parentc417a13f6eac3e002e46ba65fcd8fd182e8066c5 (diff)
downloadaur-d60e6aeb3844aa8f6e79e36c4293cc25be9e0f51.tar.gz
Fix build with Python 3.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30dd422f08b6..4a5016b5f11e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,8 +34,15 @@ conflicts=(python-pyside2)
provides=(python-pyside2 qt5-python-bindings)
replaces=(python-pyside2)
_pkgfqn=pyside-setup-opensource-src-$_qtver
-source=("https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz")
-sha256sums=('b306504b0b8037079a8eab772ee774b9e877a2d84bab2dbefbe4fa6f83941418')
+source=("https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-$pkgver-src/${_pkgfqn}.tar.xz"
+ python310.patch)
+sha256sums=('b306504b0b8037079a8eab772ee774b9e877a2d84bab2dbefbe4fa6f83941418'
+ 'ae896a09d18ef215243175fce047d8c370ab4a2d77ed0022991ed70bd23a30d0')
+
+prepare() {
+ cd ${_pkgfqn}
+ patch -Np1 -i ../python310.patch
+}
build() {
cmake -B build -S ${_pkgfqn}/sources/pyside2 \