summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2016-03-19 13:50:54 +1100
committerMatthew Gamble2016-03-19 13:50:54 +1100
commitef714bd4041eede94696942f4718842a9eb18061 (patch)
tree01036c3d6ff882944384d511bc562f5c4bee3621 /PKGBUILD
downloadaur-ef714bd4041eede94696942f4718842a9eb18061.tar.gz
Initial commit of v0.4.9 of pytg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1c8bafc5c53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Matthew Gamble
+
+pkgname=pytg
+pkgver=0.4.9
+pkgrel=1
+pkgdesc="Connect to the Telegram CLI, receive and send Telegram messages."
+arch=('any')
+url="https://pypi.python.org/pypi/pytg/${pkgver}"
+license=('GPL')
+depends=('python' 'python-dictobject' 'python-luckydonald-utils>=0.17')
+makedepends=('python-setuptools')
+source=(
+ "https://pypi.python.org/packages/source/p/pytg/pytg-${pkgver}.tar.gz"
+)
+sha256sums=('b0c3f33a1a90b5bc2252a05f3fed34e53001ac9ac647f24a1e13306307d2f84d')
+
+package() {
+ cd "pytg-$pkgver"
+ python setup.py install --root="$pkgdir"
+}