summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Gizdov2017-04-01 22:49:03 +0200
committerKonstantin Gizdov2017-04-01 22:49:03 +0200
commit96a7c2ace1bf0d5ff8ed8264078d3c94abef3dab (patch)
treeb2ddc3f2be91f683db7d0c8fa4411339d39a0aea /PKGBUILD
parent36a8d3945e637fad1d4c89c4c3927e785c6938a9 (diff)
downloadaur-96a7c2ace1bf0d5ff8ed8264078d3c94abef3dab.tar.gz
minor style fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2078cea5fc1e..fa14a36bdf11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,12 @@ pkgdesc="High-energy physics events generator."
arch=('i686' 'x86_64')
url="http://home.thep.lu.se/Pythia/"
license=('GPL')
+provides=('pythia' 'pythia8')
depends=('bash' 'boost' 'boost-libs')
optdepends=('fastjet: fast jet finding in pp and e+e- collisions'
'hepmc: storing collisions from Monte Carlo'
'lhapdf: evaluate PDFs from discretised data files'
'root: integrate with CERN ROOT data analysis framework')
-provides=('pythia' 'pythia8')
install=pythia.install
source=("http://home.thep.lu.se/~torbjorn/pythia8/$_pkgid.tgz"
"pythia.sh"
@@ -26,15 +26,16 @@ sha256sums=('36fda65eed5e9b8cd9f7e6352a4bcb56868595539fa3d2c02814c6d4b738f837'
'f1796729b0403026382bca43329692f5356c8ec46fc2c09f799a8b3d12d49a6f'
'54efb472bc7b23287125f1a4d797b08e0b85864ff727e420eaf81a6fef2ebc25')
options=('!emptydirs')
-_srcpath=$srcdir/$_pkgid
+_srcpath=${srcdir}/${_pkgid}
prepare() {
- cd $srcdir/$_pkgid
+ cd ${srcdir}/${_pkgid}
+ msg2 'Applying patches...'
patch -p1 -i ${srcdir}/respect_lib_suffix.patch
}
build() {
- cd $srcdir/$_pkgid
+ cd ${srcdir}/${_pkgid}
_inc=/usr/include/
_lib=/usr/lib/