summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2019-07-20 13:46:13 -0400
committerGI_Jack2019-07-20 13:46:13 -0400
commit332305b0af4c11bdd6714b86590cad915af7575b (patch)
tree5b143f72f099d91cd96220657984d59de97cdc79 /PKGBUILD
downloadaur-332305b0af4c11bdd6714b86590cad915af7575b.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c144c02ced34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-aadict
+_pypiname=aadict
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="An auto-attribute dict (and a couple of other useful dict functions), for Python"
+url="https://pypi.org/project/aadict/"
+arch=('any')
+license=('GPLv3')
+depends=('python')
+makedepends=('python-setuptools')
+source=(${_pypiname}-${pkgver}.tar.gz::"https://files.pythonhosted.org/packages/50/30/2d6c516ff308e1a2e25b8cf4274bd0ed763861b3d2b5cd1fb54c6d59bfcb/aadict-${pkgver}.tar.gz")
+sha256sums=('a77328ac55dbb5735da99441870251befe135f687ab707a7a178561363b27704')
+
+package() {
+ cd ${_pypiname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}