summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-01 19:39:22 -0600
committerLuis Martinez2022-03-01 19:39:22 -0600
commit9b3d9e4a3e5cc9812e4542d06e806363a9e77072 (patch)
tree9ff1e2fda4fcf0fe7fa4de59e03678fd54513d87 /PKGBUILD
parent065a6e16518598c6c537d1ed9f5350fd336c58d1 (diff)
downloadaur-9b3d9e4a3e5cc9812e4542d06e806363a9e77072.tar.gz
update to 3.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7356039d735..84105546299b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Robert Kubosz <kubosz.robert@gmail.com>
pkgname=python-abjad-ext-rmakers
-pkgver=3.5
+pkgver=3.6
pkgrel=1
pkgdesc='Abjad rhythm-maker extension'
arch=('any')
@@ -14,26 +14,20 @@ makedepends=(
'git'
'python-setuptools'
'python-build'
- 'python-install'
+ 'python-installer'
'python-wheel')
-# checkdepends=('python-pytest')
source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('B76E156E7824B5040027E7C6205943F230B622B9')
build() {
cd "$pkgname"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
-# check() {
-# cd "$pkgname"
-# pytest -x -c /dev/null abjadext
-# }
-
package() {
cd "$pkgname"
export PYTHONHASHSEED=0
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}