summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrazer2023-03-16 08:12:53 +0100
committerrazer2023-03-16 08:12:53 +0100
commit0d69aa7945a0217529db6b0724493c27569ee494 (patch)
tree29b63c031e274fac8b02c4c228e5027df2d7576d /PKGBUILD
parent54c76c8e6fc0878820a04d9a5be1650d5e05a726 (diff)
downloadaur-0d69aa7945a0217529db6b0724493c27569ee494.tar.gz
Switch to python installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5ba686d9bfa..5f249041f217 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,33 @@
pkgname=python-adafruit-circuitpython-framebuf
_pypi_pkgname=adafruit-circuitpython-framebuf
-pkgver=1.4.14
+pkgver=1.6.0
pkgrel=0
pkgdesc="CircuitPython frambuf module, based on the Python frambuf module"
-arch=('armv6h' 'armv7h')
+arch=('any')
url="https://github.com/adafruit/Adafruit_CircuitPython_framebuf"
license=('MIT')
-makedepends=('python-setuptools' 'python-pip')
-depends=('python' 'python-adafruit-blinka')
-optdepends=('python-raspberry-gpio')
+makedepends=(
+'python-build'
+'python-installer'
+'python-wheel'
+'python-setuptools-scm'
+)
+depends=(
+'python'
+'python-adafruit-blinka'
+)
+optdepends=('python-rpi-gpio')
source=("https://pypi.io/packages/source/a/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
-sha256sums=('edf9402d5456c25368c7cd5c251589a057f6db0e3ab0983f54691575a235c109')
+sha256sums=('9ad8222bc5ef91ea0bd92fd30c1eedbe540fc51e95d162b767fabe9480925f11')
build() {
cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py build || return 1
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
- python setup.py install --root=${pkgdir} --optimize=1 || return 1
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/${_pypi_pkgname}-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm644 -t "$pkgdir/usr/share/license/$pkgname" LICENSE
}