summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-02-27 09:06:19 -0600
committerLuis Martinez2022-02-27 09:06:19 -0600
commitbd49bf55b765dc446f041aa2a1c510fa5fa1996f (patch)
tree9bd77f400bb1f38c25ae8902b99ed5782d7731c8 /PKGBUILD
parenta1225b532b3892d5bddd8a52b21e844717fe0e98 (diff)
downloadaur-bd49bf55b765dc446f041aa2a1c510fa5fa1996f.tar.gz
update to 2.5.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8de894787109..2670030ffdff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Franck Lucien Duriez <franck.lucien.duriez@gmail.com>
pkgname=python-adb-enhanced
-pkgver=2.5.12
+pkgver=2.5.13
pkgrel=1
pkgdesc="Swiss-army knife for Android testing and development"
arch=("any")
url="https://github.com/ashishb/adb-enhanced"
license=("Apache")
depends=('android-tools' 'java-runtime' 'python-psutil' 'python-docopt')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('3986d149f4a6b4d80c1a75493d42b2b0b8da6f823582b9cecd4b4f497e73c3b5')
+sha256sums=('46c5ed36e7f3c93eb73ac8b76b9189827150280874aedb6ffd95c55bb86a92cd')
build() {
cd "adb-enhanced-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
## tests require an android device; do not add check
@@ -23,5 +23,5 @@ build() {
package() {
export PYTHONHASHSEED=0
cd "adb-enhanced-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
}