summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Pałubicki2019-02-28 21:42:05 +0100
committerMichał Pałubicki2019-02-28 21:42:40 +0100
commit14466b62c0d342f03cb67891144f3db8c6cd13ac (patch)
tree4a0e15a2aaaa869b3c5c4768985c40dc12ff432f /PKGBUILD
parent2f8c3c1408a29a748428c3ba9a5be85c3593a25c (diff)
downloadaur-14466b62c0d342f03cb67891144f3db8c6cd13ac.tar.gz
Let's build docs!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc71f92d0f67..fa4c9eb09e7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=agate-excel
pkgname=python-$_pkgname
pkgver=0.2.2
-pkgrel=2
+pkgrel=3
pkgdesc="Adds read support for Excel files (xls and xlsx) to agate"
arch=('any')
url="http://agate-excel.readthedocs.org/"
@@ -15,12 +15,21 @@ depends=(
'python-xlrd>=0.9.4'
'python-openpyxl>=2.3.0'
)
+makedepends=(
+ 'python-setuptools'
+ 'python-sphinx>=1.2.2'
+ 'python-sphinx_rtd_theme>=0.1.6'
+ )
source=("https://github.com/wireservice/agate-excel/archive/${pkgver}.tar.gz")
sha256sums=('37acbc114c4c60aa37f908d93a9e9b597c3ba0ee42672f36f7a317f8af8fc581')
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+
+ python setup.py build_sphinx
+ mkdir -p "$pkgdir/usr/share/doc"
+ cp -rv "$srcdir/$_pkgname-$pkgver/build/sphinx/html" "$pkgdir/usr/share/doc/$_pkgname"
}
# vim:set ts=2 sw=2 et: