summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Pałubicki2019-02-28 21:41:19 +0100
committerMichał Pałubicki2019-02-28 21:41:19 +0100
commit2f8c3c1408a29a748428c3ba9a5be85c3593a25c (patch)
tree959ecb9364893a60209f138ad26bd373b8d9c885 /PKGBUILD
parentaf0d4446b48bff5cc3cb8d7f11997140f69e1c98 (diff)
downloadaur-2f8c3c1408a29a748428c3ba9a5be85c3593a25c.tar.gz
Cleaning up dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0113a620c875..fc71f92d0f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,23 @@
_pkgname=agate-excel
pkgname=python-$_pkgname
pkgver=0.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Adds read support for Excel files (xls and xlsx) to agate"
arch=('any')
url="http://agate-excel.readthedocs.org/"
license=('MIT')
-depends=('python'
- 'python-nose'
- 'python-tox'
- 'python-sphinx'
- 'python-sphinx_rtd_theme'
- 'python-wheel'
- 'python-xlrd'
- 'python-openpyxl'
- 'python-agate')
-
+depends=(
+ 'python'
+ 'python-agate>=1.5.0'
+ 'python-xlrd>=0.9.4'
+ 'python-openpyxl>=2.3.0'
+ )
source=("https://github.com/wireservice/agate-excel/archive/${pkgver}.tar.gz")
+sha256sums=('37acbc114c4c60aa37f908d93a9e9b597c3ba0ee42672f36f7a317f8af8fc581')
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
}
-sha256sums=('37acbc114c4c60aa37f908d93a9e9b597c3ba0ee42672f36f7a317f8af8fc581')
-
# vim:set ts=2 sw=2 et: