summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Pohl2015-12-07 20:48:02 +0100
committerChristoph Pohl2015-12-07 20:48:02 +0100
commit730fd7593d2cb9b4c19599b5e810b1af1a62f9b6 (patch)
treef83aa45c07d2b4b4ace6d97f2a9ea992a1595c70 /PKGBUILD
downloadaur-python-ahkab.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a26d8c8f5fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Christoph Pohl <christophpohl@gmx.com>
+pkgname=python-ahkab
+pkgver=0.18
+pkgrel=1
+pkgdesc="A SPICE-like electronic circuit simulator written in Python"
+arch=('any')
+url="https://ahkab.github.io/ahkab/"
+license=('GPL2')
+depends=('python-numpy' 'python-scipy' 'python-sympy' 'python-tabulate')
+optdepends=('python-matplotlib: plotting')
+source=("ahkab-$pkgver.tar.gz::https://github.com/ahkab/ahkab/archive/v$pkgver.tar.gz")
+md5sums=('9f82ed50cf654e87437713a87ced4f1f')
+
+package() {
+ cd "$srcdir/ahkab-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}