summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrikilinux2021-12-16 19:20:28 -0300
committerFrikilinux2021-12-16 19:20:28 -0300
commitf4df307075e86c6f368e646e50e5ecdabdc997dd (patch)
tree74e942e5c752d54aed16085886a59b236be73247 /PKGBUILD
parentea59696ba032125c8181eeb167252d38100b0bae (diff)
downloadaur-f4df307075e86c6f368e646e50e5ecdabdc997dd.tar.gz
Update to new version. Clean sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3639444c0463..e159dfb6f3c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer : Frikilinux <frikilinux@gmail.com>
+# Contributor : peeweep <peeweep at 0x0 dot ee>
pkgname=python-aigpy
_pkgname=aigpy
@@ -9,28 +10,22 @@ arch=('any')
url="https://github.com/yaronzz/AIGPY"
license=('MIT')
depends=(
- 'python'
'python-requests'
'python-colorama'
'python-mutagen'
)
makedepends=('python-setuptools')
-source=(
- "https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/yaronzz/AIGPY/master/LICENSE")
-sha256sums=('838aaaf62efb2a48847f07948cce0dc1a209828807545b914065b25c4e50c38d'
- '83e4dd21429a91fb7cea67a476032a9641425e5355df2e0f589a738b6ec9fd2c')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+
+sha256sums=('838aaaf62efb2a48847f07948cce0dc1a209828807545b914065b25c4e50c38d')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
-
}
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
- install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: