summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2016-07-27 18:01:23 +0200
committerPhilipp A2016-07-27 18:01:23 +0200
commita330615a0b88d456d96a32858f5cbd880a75842d (patch)
tree3e58665b625c723c8c9ff6652270541e4844858e /PKGBUILD
parentcec80adec95c62aeb6dea94a95dcd27183181194 (diff)
downloadaur-a330615a0b88d456d96a32858f5cbd880a75842d.tar.gz
version 0.22.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2e553ceec3f..7c0924740a11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,32 @@
# Maintainer: Phil Schaf <flying-sheep@web.de>
_name=aiohttp
pkgname=python-aiohttp
-pkgver=0.22.1
+pkgver=0.22.3
pkgrel=1
pkgdesc='http client/server for asyncio'
-arch=('i686' 'x86_64')
+arch=('any')
url="http://pypi.python.org/pypi/$_name"
license=('Apache')
-depends=('python>=3.4.1' 'python-chardet')
+depends=('python>=3.5' 'python-chardet' 'python-multidict')
makedepends=('python-pip')
_wheelbase="$_name-$pkgver-cp35-cp35m-manylinux1"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
source_i686=( "https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_i686.whl")
source_x86_64=("https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_x86_64.whl")
noextract=("${_wheelbase}_"{i686,x86_64}.whl)
-md5sums_i686=('0c34e293ffb2621748cc4eb9e9a6ebb1')
-md5sums_x86_64=('a03fd8f590a201b5b4026e8b5157dbf2')
+md5sums=('8c75aa7aad0c428a0dbed1380e9c0807')
+md5sums_i686=('f50387b72362cc798e4c8a8e20ffa78c')
+md5sums_x86_64=('b85e5c06ab167ec0d585d436d44f4e62')
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "${_wheelbase}_$CARCH.whl"
+ case "$CARCH" in
+ i686|x86_64)
+ cd "$srcdir"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "${_wheelbase}_$CARCH.whl"
+ ;;
+ *)
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ ;;
+ esac
}