summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2017-01-09 17:29:27 +0100
committerPhilipp A2017-01-09 17:30:21 +0100
commitf2e63e0cf8025725403b257bb875110346171db2 (patch)
treef2949df06bec283f6b55495e6f3f8bf32503ad69 /PKGBUILD
parent551881f5ebe071e5abacc8d8927429f784f6c4c6 (diff)
downloadaur-f2e63e0cf8025725403b257bb875110346171db2.tar.gz
build from source until 3.6 wheels exist
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72f57bdf72a2..e8a202602d7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Philipp A. <flying-sheep@web.de>
_name=aiohttp
pkgname=python-aiohttp
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.1.6
+pkgrel=2
pkgdesc='http client/server for asyncio'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://pypi.python.org/pypi/$_name"
@@ -11,20 +11,22 @@ depends=('python>=3.5' 'python-chardet' 'python-multidict' 'python-async-timeout
makedepends=('python-pip')
# binary packages
-_wheelbase="$_name-$pkgver-cp35-cp35m-manylinux1"
-source_i686=( "https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_i686.whl")
-source_x86_64=("https://files.pythonhosted.org/packages/cp35/${_name::1}/$_name/${_wheelbase}_x86_64.whl")
-md5sums_i686=('3f28ee44ff624f305f379b1b751a16a2')
-md5sums_x86_64=('a97f7471ae6c72c1b774b8bf98b562a5')
-noextract=("${_wheelbase}_"{i686,x86_64}.whl)
+#_wheelbase="$_name-$pkgver-cp36-cp36m-manylinux1"
+#source_i686=( "https://files.pythonhosted.org/packages/cp36/${_name::1}/$_name/${_wheelbase}_i686.whl")
+#source_x86_64=("https://files.pythonhosted.org/packages/cp36/${_name::1}/$_name/${_wheelbase}_x86_64.whl")
+#md5sums_i686=('')
+#md5sums_x86_64=('')
+#noextract=("${_wheelbase}_"{i686,x86_64}.whl)
# source code package
_s="https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+source=("$_s")
source_arm=("$_s")
source_armv6h=("$_s")
source_armv7h=("$_s")
source_aarch64=("$_s")
-_m=('a7b25d51bf887ec4f9b87463a6bff6d4')
+_m=('dc080616b14155a202288bb3dbf07f8b')
+md5sums=("$_m")
md5sums_arm=("$_m")
md5sums_armv6h=("$_m")
md5sums_armv7h=("$_m")
@@ -32,10 +34,10 @@ md5sums_aarch64=("$_m")
package() {
case "$CARCH" in
- i686|x86_64)
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "${_wheelbase}_$CARCH.whl"
- ;;
+# i686|x86_64)
+# cd "$srcdir"
+# pip install --compile --no-deps --ignore-installed --root="$pkgdir" "${_wheelbase}_$CARCH.whl"
+# ;;
*)
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1