summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustav Sörnäs2024-03-18 12:29:16 +0100
committerGustav Sörnäs2024-03-18 12:29:35 +0100
commit283aa6b4a7012016d6bdfec005dec149bb24f94f (patch)
tree2c1850c074fa9861ef14a36290bcac58566dbc22 /PKGBUILD
downloadaur-283aa6b4a7012016d6bdfec005dec149bb24f94f.tar.gz
initial upload: 2.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d5e37727733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustav Sörnäs <gustav@sornas.net>
+# vim: ts=2 sw=2 et:
+
+pkgname=python-aiohttp-sse
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="Server-sent events support for aiohttp"
+arch=('x86_64')
+url="https://github.com/aio-libs/aiohttp-sse"
+license=('Apache')
+depends=('python' 'python-aiohttp')
+optdepends=()
+makedepends=('python-build' 'python-installer')
+checkdepends=('python-pytest' 'python-pytest-aiohttp' 'python-pytest-asyncio' 'python-pytest-cov')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+prepare() {
+ mv ${pkgname/python-/}-$pkgver $pkgname-$pkgver
+}
+
+build() {
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd $pkgname-$pkgver
+ PYTHONPATH="$PWD/build/lib/" pytest
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}