summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsti2d2018-02-18 08:21:13 +0100
committersti2d2018-02-18 08:21:13 +0100
commit34401681733911e15d33a1eaf191dba295d36048 (patch)
tree5b0a6273a932e0aa372aedfb3e72075a69003c2b /PKGBUILD
downloadaur-34401681733911e15d33a1eaf191dba295d36048.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d472b046044
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Razer <razer[AT]neuf[DOT]fr>
+
+pkgname=python-aioredis
+_pypi_pkgname=aioredis
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="asyncio (PEP 3156) Redis client library"
+arch=(any)
+url="https://github.com/aio-libs/aioredis"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python' 'redis')
+source=("https://pypi.io/packages/source/a/${_pypi_pkgname}/${_pypi_pkgname}-${pkgver}.tar.gz")
+md5sums=('a839519aac8186f0fcd279eab0c394fc')
+
+build() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/${_pypi_pkgname}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+}