summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeter Cai2016-10-03 14:28:24 +0800
committerPeter Cai2016-10-03 14:28:24 +0800
commitb96d5819eb68c8a818e59ffa2379162748ec6127 (patch)
tree42580b669ce1f40f1106fa812862e4777abe7cc2 /PKGBUILD
downloadaur-b96d5819eb68c8a818e59ffa2379162748ec6127.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ecec7a52e58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Peter Cai <peter at typeblog dot net>
+
+_pkgname=aiosocks
+pkgname=python-aiosocks
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="SOCKS proxy client for asyncio and aiohttp"
+arch=("any")
+license=("APACHE-2")
+depends=("python>=3.4" "python-setuptools")
+optdepends=("python-aiohttp: For aiosocks.SocksConnector")
+source=("https://pypi.python.org/packages/cd/d5/f522e746a07b0e454dc1d909d1494d55f7da6bc0e4671e27175691046a95/aiosocks-0.1.7.zip")
+md5sums=('46b2c6564e8af97ce6a8ad66fe632de3')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+}