summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 19:45:47 -0700
committerGI_Jack2023-05-13 19:45:47 -0700
commit964442d20f550dde45b152aa19660cfd62fd907e (patch)
tree5cf3246de963be1045bf0ddb1268aa829f81e6a0 /PKGBUILD
parent0fea9815df7270ed0b28e0d3244773795fa32818 (diff)
downloadaur-964442d20f550dde45b152aa19660cfd62fd907e.tar.gz
version 0.0.9
updated for modern packaging guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b6ae9937f4e..398a9d64ed41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
pkgname=python-aiowinreg
_pkgname=aiowinreg
-pkgver=0.0.7
+pkgver=0.0.9
pkgrel=1
pkgdesc="Windows registry file reader, written in python"
-url="https://pypi.org/project/aiowinreg"
+url="https://github.com/skelsec/aiowinreg"
arch=('any')
license=('MIT')
-depends=('python' )
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('a191c039f9c0c1681e8fc3a3ce26c56e8026930624932106d7a1526d96c008dd')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+source=("https://github.com/skelsec/aiowinreg/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('55b59dec411661d7042a9a7f4091a6ce83483f701fea517e91ced22643bfa92e')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}