summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-11-18 07:11:37 +0200
committerDimitris Kiziridis2020-11-18 07:11:37 +0200
commitecb5ee66ad922602307bc58041e455d964b7d2b1 (patch)
tree1bfd2416ca5aa6f246601eeba18333d9bb832c9a /PKGBUILD
parent17ae2d45703577f5ea09a6e2686d2887c5750525 (diff)
downloadaur-ecb5ee66ad922602307bc58041e455d964b7d2b1.tar.gz
Update to 0.7.17
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 603a58f00ab2..d6a12739194e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=python-akshare
-pkgver=0.5.18
+pkgver=0.7.17
pkgrel=1
pkgdesc="AkShare is an elegant and simple financial data interface library for Python, built for human beings"
arch=('any')
@@ -16,24 +16,20 @@ depends=('python-beautifulsoup4'
'python-requests'
'python-urllib3'
'python-demjson'
- 'python-pyexecjs'
'python-pillow'
'python-pinyin'
'python-websocket-client'
- 'python-pycryptodomex'
'python-html5lib'
- 'python-requests-html'
- 'python-scikit-learn'
- 'python-fonttools'
'python-xlrd'
'python-tqdm'
'python-openpyxl'
'python-jsonpath-ng'
'python-tabulate'
- 'python-decorator')
+ 'python-decorator'
+ 'python-pyminiracer')
makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/jindaxiang/akshare/archive/v${pkgver}.tar.gz")
-sha256sums=('8db7bf3214d3cd08d50c3df1f290db973683d38b8b16e9ac4a8696485481ac28')
+sha256sums=('3b89c798c5ced054b895671205c416b992fb500f86fd043daa58ee4c57719b63')
build() {
cd ${srcdir}/akshare-${pkgver}
@@ -44,4 +40,4 @@ package() {
cd ${srcdir}/akshare-${pkgver}
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+}