summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRiccardo Berto2017-08-25 09:05:42 +0200
committerRiccardo Berto2017-08-25 09:05:42 +0200
commit5a2d08eb698501bcf90492b17c266e063852c92d (patch)
tree2d9195df82f4e6b9031590bf45b2d59618740828 /PKGBUILD
downloadaur-5a2d08eb698501bcf90492b17c266e063852c92d.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e7a9498a66b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Riccardo Berto <riccardobrt at gmail dot com>
+# Contributor: tembleking <tembleking at gmail dot com>
+
+pkgname='python-alpha-vantage'
+_pkgname='alpha_vantage'
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Python Client for Google Maps Services"
+arch=("any")
+url="https://github.com/RomelTorres/alpha_vantage"
+license=('MIT')
+depends=("python" "python-requests" "python-simplejson" "python-pandas")
+makedepends=("python-setuptools")
+source=("https://github.com/RomelTorres/alpha_vantage/archive/$pkgver.tar.gz")
+md5sums=('af8162d2a59dcdb95b16b75e20417584')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}