summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2023-05-16 21:44:53 +0200
committerNarrat2023-05-16 21:44:53 +0200
commit52467b317921e209a66d8dd11252b33de485da01 (patch)
treef254d9e63cc3566e2f6b446a384b685c95a72b6a /PKGBUILD
parentf31614f345107e9431d2fd8e35ef5b743f3d1109 (diff)
downloadaur-52467b317921e209a66d8dd11252b33de485da01.tar.gz
altair: add uptream patch for misplaced files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3424958b56c9..c55505339ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=python-altair
_pyname=altair
pkgname=('python-altair')
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Declarative statistical visualization library for Python"
arch=('any')
url="https://altair-viz.github.io/"
@@ -13,10 +13,17 @@ license=('BSD3')
depends=(python-jinja python-jsonschema python-numpy python-pandas python-toolz)
makedepends=(python-build python-installer python-wheel python-hatchling)
optdepends=('python-selenium: png and svg export support')
-source=("${_pyname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz")
-sha256sums=('394c3d8be96f9cc90e15a0eee3634cc5b6f19e470fd2045759892623bd9a3fb2')
+source=("${_pyname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz"
+ 0001_pyproject.patch)
+sha256sums=('394c3d8be96f9cc90e15a0eee3634cc5b6f19e470fd2045759892623bd9a3fb2'
+ '9c67444c235e8f0b1a3aaabfa0787afda9f2b0470a361c112efc202c8432831b')
+prepare() {
+ cd ${_pyname}-${pkgver}
+ patch -Np1 -i "${srcdir}"/0001_pyproject.patch
+}
+
build () {
cd "${_pyname}-${pkgver}"
python -m build --wheel --no-isolation
@@ -27,9 +34,6 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
-
- # Remove unnecessary and wrongly installed files
- rm -v "$pkgdir"/usr/lib/python3.11/site-packages/{README.md,LICENSE,pyproject.toml}
}
# vim:set et sw=2 ts=2 tw=79: