summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorScott Alfter2024-06-11 09:58:46 -0700
committerScott Alfter2024-06-11 09:58:46 -0700
commitc2d0f7fa67307551628267ea5d579522be7bc95d (patch)
tree96bb970188fba0ee76bd685f6ade6fc6d4ad6a06 /PKGBUILD
parent79946314a60b2c4b16dc84328e36bd21cb2c1054 (diff)
downloadaur-c2d0f7fa67307551628267ea5d579522be7bc95d.tar.gz
applied suggested fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49b550d1ff69..af35f0eeeb3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=(any)
url="https://github.com/amaranth-lang/amaranth"
license=('BSD')
depends=('python' 'python-jinja' 'python-pyvcd')
-makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm' 'python-jschon')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm' 'python-jschon' 'python-packaging' 'python-pdm-backend')
optdepends=('python-paramiko: for remote builds')
# FIXME: symbiyosys
checkdepends=('python-pytest' 'yosys>0.16' 'symbiyosys-git' 'yices')
@@ -20,11 +20,9 @@ conflicts=('python-nmigen' "python-nmigen-git" "python-$_pkgname-git")
replaces=('python-nmigen')
source=(
"git+$url.git"
- amaranth-versioning.patch
)
sha256sums=(
'SKIP'
- '4a6582f9490af97b04d979b13f0ca3127c96d46788b27131ae3aaa7467524131'
)
pkgver() {
@@ -37,7 +35,7 @@ prepare()
{
cd "$_pkgname"
git checkout $_git_commit
- patch -p1 -i ${srcdir}/amaranth-versioning.patch
+ sed -i -e "s/pdm\\.backend\\._vendor\\.//" pdm_build.py
}
build() {