summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXeonacid2021-04-27 17:16:32 +0800
committerXeonacid2021-04-27 17:16:32 +0800
commit4bcf6f9eb5987bbdbb62fbbc9c579da00a06dbfa (patch)
tree96a560fe108c385887e35a1302bdaa96d17b7a5a /PKGBUILD
downloadaur-python-ancypwn-terminal-alacritty.tar.gz
Bump 0.0.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1aa53ec68201
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Xeonacid <h.dwwwwww at gmail dot com>
+
+pkgname=python-ancypwn-terminal-alacritty
+_pkgname="${pkgname#*-}"
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="ancypwn terminal plugin"
+arch=('any')
+url="https://github.com/Escapingbug/ancypwn-terminal-alacritty"
+license=('unknown')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('47917effdf0218d684008c339743e1a435df21db72c569e4ab1a038fd0edcc56')
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}