summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-01-18 21:45:27 +0100
committerNarrat2020-01-18 21:46:28 +0100
commitb59d6611454a4a930605c9fc05a2ebf763ae46ca (patch)
treee621a455fccf4a9c0ac4508d91bae4581a8ca078 /PKGBUILD
parent0cceb9a8ed97fc83f7d76449e0a0ca14630bfa35 (diff)
downloadaur-python-antspy.tar.gz
bump to 0.2.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 17 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5c7150b46d1e..5fb045dbe9f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,11 @@
-# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
-_pkgname=antspy
-pkgname=python-$_pkgname
-pkgver=0.1.5
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Martino Pilia <martino.pilia@gmail.com>
+
+_pkgname=ANTsPy
+pkgname=python-antspy
+pkgver=0.2.2
pkgrel=2
+_commit=1d4148c0b2e67ba5595f81264a6143c9aa38a839
pkgdesc="Advanced Normalization Tools (ANTs) in Python"
arch=('any')
url="https://github.com/ANTsX/ANTsPy"
@@ -10,23 +13,17 @@ license=('apache')
depends=('python' 'python-numpy' 'python-webcolors' 'insight-toolkit')
optdepends=('python-plotly: surface rendering')
makedepends=('python-setuptools')
-source=("ANTsPy-$pkgver::git+https://github.com/ANTsX/ANTsPy.git")
-sha512sums=('SKIP')
-# source=("https://github.com/ANTsX/ANTsPy/archive/v${pkgver}.tar.gz")
-# sha512sums=('0d6a9bc0d33c8969ce95beca08a771fda5bdf73837c78840ec405c89787656e2cb40174706b9981eb31f02c9fae9db818c58acbbfa3c2f903dc6b7b33befa3ed')
-
-# This commit includes some fixes that allow to compile against ITKv5
-_release_commit=7a8796b5204fccb6158e79453cd781811c063b3d
-
-package() {
- cd "$srcdir/ANTsPy-$pkgver"
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/ANTsX/ANTsPy/archive/v${pkgver}.tar.gz")
+sha512sums=('e3f580a3164c273fd8a1d65227f38806a5cf17c3de1a2beca0c80d3ef8dcc8c52c3d619e38225f429555d89228768a720ce38a03b47e929848d3c2b1ed4c5802')
- git checkout $_release_commit
- # Include a bugfix in the version of ANTs used, otherwise it will not compile
- sed -i '521s,1d5d805c8a2f29f71050488caa7314aae1ef1520,45c37d92c9855325ba9ba1fd5ee131d547d8efb6,' scripts/configure_ANTsPy.sh
-
- export ITK_DIR="/usr"
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
- python setup.py install --optimize=1 --root="${pkgdir}"
+package() {
+ cd "$_pkgname-$pkgver"
+ export ITK_DIR="/usr"
+ python setup.py install --optimize=1 --root="${pkgdir}" --skip-build
}