summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-21 21:03:44 +1100
committerPumpkinCheshire2020-11-21 21:03:44 +1100
commit67480f9b59f3e8aa565839ee4bc5894b0df19496 (patch)
tree112f55f39282ed24bc8ace846e554ba96a81e65e /PKGBUILD
parent47f2830e39e8c7dcf13f0855c8278062b6217012 (diff)
downloadaur-67480f9b59f3e8aa565839ee4bc5894b0df19496.tar.gz
add more backend as optdepends, add conflicts with git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97b94c93fb31..fec5428358b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,23 @@
pkgname=python-anyconfig
_name=anyconfig
pkgver=0.9.11
-pkgrel=2
+pkgrel=3
pkgdesc='Python library provides common APIs to load and dump configuration files in various formats'
url='https://github.com/ssato/python-anyconfig'
arch=('any')
license=('MIT')
-depends=('python-toml' 'python-simplejson' 'python-ruamel-yaml' 'python-jinja' 'python-yaml' 'python-jmespath' 'python-jsonschema')
+depends=('python-toml' 'python-ruamel-yaml' 'python-jinja' 'python-jmespath' 'python-jsonschema')
+optdepends=('python-simplejson: Replace standard json backend'
+ 'python-yaml: YAML support if ruamel.yaml is not aviliable'
+ 'python-anyconfig-bson-backend: BSON support using pymongo'
+ 'python-anyconfig-ion-backend: Amazon ion load and dump support'
+ 'python-anyconfig-cbor-backend: CBOR support using cbor'
+ 'python-anyconfig-cbor2-backend: CBOR support using cbor2'
+ 'python-anyconfig-configobj-backend: ConfigObj load and dump support'
+ 'python-anyconfig-msgpack-backend: MessagePack load and dump support'
+)
makedepends=('python-setuptools')
+conflicts=('python-anyconfig-git')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('8888130cde5461cb39379afdd1d09b1b1342356210f0a6743a4b60f9973226f8')