summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-21 20:20:35 +1100
committerPumpkinCheshire2020-11-21 20:20:35 +1100
commit899d994498330ff3f6021686c6a2705b228a79c4 (patch)
treebbe1420ba0b4ab83edd5986dc476bd7599e2a4bb /PKGBUILD
downloadaur-899d994498330ff3f6021686c6a2705b228a79c4.tar.gz
init 0.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ec11d0bd838
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+
+_name=anyconfig-cbor-backend
+pkgname=python-$_name
+pkgver=0.1.2
+pkgrel=1
+pkgdesc='This is a backend module for python-anyconfig to support to load and dump CBOR files with using cbor.'
+url='https://github.com/ssato/python-anyconfig-cbor-backend'
+arch=('any')
+license=('MIT')
+depends=('python-anyconfig' 'python-cbor')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('095a01db7057b808cd29c5b63a6a808aedc5d97b7fd58c1ddb310e1b8c9a1a05')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
+}