summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArjun Nemani2018-07-08 21:23:07 +0530
committerArjun Nemani2018-07-08 21:23:07 +0530
commitfa5ef1183e27552621bc0710bd5cb71267814837 (patch)
treed1d85a1f5808a30e2618d9a15959fe4f5e5f8b2e /PKGBUILD
downloadaur-fa5ef1183e27552621bc0710bd5cb71267814837.tar.gz
Add npm apertium-lint to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91f3121d7ab3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# PKGBUILD generated by pipman
+# Python package author: Jaipal Singh Goud <jpsinghgoud@gmail.com>
+pkgname=python-apertium-lint
+pkgver=0.29
+pkgrel=1
+pkgdesc="Linters for Apertium Rule Based Machine Translation Platform"
+arch=(any)
+url="https://svn.code.sf.net/p/apertium/svn/trunk/apertium-tools/apertium-lint/"
+license=(MIT)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="apertium-lint" apertium-lint
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.5/site-packages/
+ cp -r $srcdir/apertium-lint/* $pkgdir/usr/lib/python3.5/site-packages/
+} \ No newline at end of file