summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-09-04 18:23:56 -0600
committerMark Wagie2021-09-04 18:23:56 -0600
commit42a1512f19670ae6576a102c696b16da2e2f6fb4 (patch)
tree1e8feb869af0857241c3a3aad98e9f840b9a6ea1 /PKGBUILD
downloadaur-42a1512f19670ae6576a102c696b16da2e2f6fb4.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a6f98de9463
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-app_paths
+_name=${pkgname#python-}
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="Like appdirs, but with pathlib, path creation and async support."
+arch=('any')
+url="https://github.com/alexdelorenzo/app_paths"
+license=('LGPL3')
+depends=('python-strenum' 'python-aiopath' 'python-anyio' 'python-appdirs'
+ 'python-typing_extensions' 'python-unpackable' 'python-asyncstdlib')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
+ 'https://raw.githubusercontent.com/alexdelorenzo/app_paths/master/requirements.txt')
+sha256sums=('0ae3f8a8d451539842d49124e173016671c1553e7df4e595cc8837041febf46f'
+ 'e348c437253dbbf7a61470400566b4f5edd7b5f8054a20b0c27158c078c68783')
+
+prepare() {
+ cp requirements.txt "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}