summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 09:24:49 -0600
committerMark Wagie2022-04-15 09:24:49 -0600
commitc7dcabd7d4cbdc274fd8193e2bd9b609ccecf0e4 (patch)
treebb9e0daaeebbd46883cd8f207d11b8c322aa6b4e /PKGBUILD
parente75a830718550b7e7c988bfbab8cf08c5236dd86 (diff)
downloadaur-c7dcabd7d4cbdc274fd8193e2bd9b609ccecf0e4.tar.gz
standards based build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e337182225df..568766aa5055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=python-app_paths
_name=${pkgname#python-}
pkgver=0.0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Like appdirs, but with pathlib, path creation and async support."
arch=('any')
url="https://github.com/alexdelorenzo/app_paths"
license=('LGPL3')
depends=('python-strenum' 'python-aiopath' 'python-anyio' 'python-appdirs'
'python-typing_extensions' 'python-unpackable' 'python-asyncstdlib')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
'https://raw.githubusercontent.com/alexdelorenzo/app_paths/master/requirements.txt')
sha256sums=('0ae3f8a8d451539842d49124e173016671c1553e7df4e595cc8837041febf46f'
@@ -21,10 +21,10 @@ prepare() {
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}