summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordobedobedo2022-02-08 15:27:41 +0300
committerdobedobedo2022-02-08 15:27:41 +0300
commite36c0110be84483cdcad4f6d5676bc982d4bcd5e (patch)
tree671fa35c40bd1e2e1af95145437f42fa2de9b0b1 /PKGBUILD
downloadaur-e36c0110be84483cdcad4f6d5676bc982d4bcd5e.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21a6a0b5ba88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: dobedobedo <dobe0331 at gmail dot com>
+# Contributor: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_pkgname='arcsi'
+pkgname=("python-$_pkgname")
+pkgver=3.8.1
+pkgrel=1
+pkgdesc="Atmospheric and Radiometric Correction of Satellite Imagery"
+arch=('any')
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-rsgislib' 'python-kealib' 'gdal' 'python-rios' 'python-py6s')
+options=(!emptydirs)
+source=("https://github.com/remotesensinginfo/arcsi/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('83b069487e363b26de6a2708256b55846e19a6a8a906086ac025152268208877')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}