summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMédéric Boquien2021-09-19 19:21:35 -0300
committerMédéric Boquien2021-09-19 19:21:35 -0300
commit6fcba8eb6d1a4aee14ccfd2e408773a93df2784a (patch)
treed795e85b7af02d8b6db0f9368846f1bc3fdf5b3d /PKGBUILD
parent48ca283a5fd0babfca58614b192984396a188284 (diff)
downloadaur-6fcba8eb6d1a4aee14ccfd2e408773a93df2784a.tar.gz
Switch back to setup.py as it appears to be fixed now. Patch by Luis Martinez.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a8474521694..287a64892ace 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Contributor: Médéric Boquien <mboquien@free.fr>
# Maintainer: Médéric Boquien <mboquien@free.fr>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+
pkgname=python-astropy
pkgver=4.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A community python library for astronomy"
arch=('i686' 'x86_64')
url="http://www.astropy.org/"
@@ -26,22 +27,19 @@ optdepends=('python-scipy: powers a variety of features in several modules'
'libxml2: validates VOTABLE XML files. This is a command line tool installed outside of Python'
)
conflicts=('python-pyfits' 'python-vo')
-makedepends=('cython' 'python-jinja' 'python-pip' 'python-setuptools-scm' 'python-extension-helpers')
+makedepends=('cython' 'python-jinja' 'python-setuptools-scm' 'python-extension-helpers')
source=("https://files.pythonhosted.org/packages/source/a/astropy/astropy-${pkgver}.tar.gz")
sha512sums=('ca674ef9773ddce33e8849c41e3ed8a5bf66fc8b983f6bc9cfd82f1c7c282bbb05f59ab48a112c21c0ec6895b5e8982b1067e5ae97f21c9d63527a78bd0a8ad7')
build() {
cd "${srcdir}/astropy-${pkgver}"
# Temporarily disable the use of the system cfitsio, as astropy is broken as it only tracks an old bundled version with a slightly different API
- #ASTROPY_USE_SYSTEM_ALL=1 PIP_CONFIG_FILE=/dev/null pip wheel --no-cache-dir --no-deps --wheel-dir="${srcdir}/astropy-${pkgver}" .
- ASTROPY_USE_SYSTEM_WCSLIB=1 ASTROPY_USE_SYSTEM_EXPAT=1 ASTROPY_USE_SYSTEM_ERFA=1 PIP_CONFIG_FILE=/dev/null pip wheel --no-cache-dir --no-deps --wheel-dir="${srcdir}/astropy-${pkgver}" .
+ ASTROPY_USE_SYSTEM_WCSLIB=1 ASTROPY_USE_SYSTEM_EXPAT=1 ASTROPY_USE_SYSTEM_ERFA=1 python setup.py build
}
package() {
cd "${srcdir}/astropy-${pkgver}"
- install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
- install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
- PIP_CONFIG_FILE=/dev/null pip install --isolated --ignore-installed --no-deps --no-warn-script-location --root="${pkgdir}" "$(ls ./*.whl 2> /dev/null)"
- rm "${pkgdir}"/usr/lib/python*/site-packages/astropy-"${pkgver}".dist-info/direct_url.json
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}