summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2023-06-08 19:51:42 -0700
committerGI_Jack2023-06-08 19:51:42 -0700
commit7f19f9fa273689d6ca1785bbf25ab6053ea90e19 (patch)
treef4c854d92287f76854391ae64298065e69a9fb5d /PKGBUILD
downloadaur-7f19f9fa273689d6ca1785bbf25ab6053ea90e19.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea91dcc790cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-asyauth
+_pkgname=asyauth
+pkgver=0.0.14
+pkgrel=1
+pkgdesc="Unified authentication library, written in python"
+url="https://github.com/skelsec/asyauth"
+arch=('any')
+license=('MIT')
+
+depends=( 'python>=3.7' 'python-unicrypto>=0.0.10' 'python-asn1crypto>=1.3.0'
+'python-asysocks' 'python-minikerberos' 'python-winacl')
+
+makedepends=('python-build' 'python-installer' 'python-wheel'
+'python-setuptools>=61.0.0')
+
+source=("https://github.com/skelsec/asyauth/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('f9911a039cf17b481ae7e7c559fae8f3c8d8c1b7158c85359014e2d7d2546a30')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ rm -rf tests # conflicts with other packages
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}