summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrew DeVault2017-07-08 10:23:07 -0400
committerDrew DeVault2017-07-08 10:23:07 -0400
commita5eaecd112893edc59e0c61ab3fb8f9e319e4260 (patch)
tree8d640f2eddd971b2880ddea6afb127bb89689957 /PKGBUILD
downloadaur-a5eaecd112893edc59e0c61ab3fb8f9e319e4260.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba92bd94f6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname="python-asyncio_redis"
+_name=asyncio_redis
+pkgver=0.14.3
+pkgrel=1
+pkgdesc="PEP 3156 implementation of the redis protocol."
+arch=("any")
+url="https://pypi.python.org/pypi/asyncio_redis"
+license=("2 clause BSD")
+depends=("python")
+makedepends=("python-distribute")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('fae40dc59c7268dfb9a44542cb3f48a885c8f5f7438b13f0dfec1fbd10a82369')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}