summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGI_Jack2020-09-30 12:23:31 -0400
committerGI_Jack2020-09-30 12:23:31 -0400
commitf4bebd8635b548f144a6635b63a7122e6055e335 (patch)
treef11f36edb3072626e077447e7a44f00bada7f91a /PKGBUILD
parent321ebfadf993ba09fd967ab3da5695911b2d3103 (diff)
downloadaur-f4bebd8635b548f144a6635b63a7122e6055e335.tar.gz
updated with AUR best practices for python
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa49b94482dc..8bf8c94ad133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: GI_Jack <GI_Jack@hackermail.com>
pkgname=python-asysocks
-_pypiname=asysocks
+_pkgname=asysocks
pkgver=0.0.7
_file="d7/34/c8895dbc82c231a463ca63c1c9b664eb410d6b423885219e336b573f64ab"
pkgrel=1
@@ -11,10 +11,10 @@ arch=('any')
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=(${_pypiname}-${pkgver}.tar.gz::"https://files.pythonhosted.org/packages/${_file}/asysocks-${pkgver}.tar.gz")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('c7eaa6c178bbd65d590a798ef8fba4f98c2a3240fa0a5fd28b1ec935edca4963')
package() {
- cd ${_pypiname}-${pkgver}
+ cd ${_pkgname}-${pkgver}
python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
}