summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-10-11 10:00:08 +1300
committerGeorge Rawlinson2022-10-11 10:00:08 +1300
commitafd54dca8e27ead6ab50dc93373854e21b7626c2 (patch)
tree8e62dfc67217f51549f1c2271fd4c38080fbaac6 /PKGBUILD
downloadaur-afd54dca8e27ead6ab50dc93373854e21b7626c2.tar.gz
addpkg: python-atheris 2.0.12-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91aa5df64592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=python-atheris
+pkgver=2.0.12
+pkgrel=1
+pkgdesc='A coverage-guided fuzzer for Python and Python extensions'
+arch=('x86_64')
+url='https://github.com/google/atheris/'
+license=('Apache')
+depends=('python')
+makedepends=(
+ 'git'
+ 'clang'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools'
+ 'pybind11'
+)
+_commit='cbd372db6a61577566b967587b12fd934b937f2d'
+source=("$pkgname::git+$url#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ # https://github.com/google/atheris/issues/45
+ git describe --tags | sed 's/^v//'
+
+ #grep ATHERIS_VERSION setup.py | sed -e 's/.*ATHERIS_VERSION", "\(.*\)")/\1/'
+}
+
+build() {
+ cd "$pkgname"
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$pkgname"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}