summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2023-03-30 20:20:02 +0800
committerlilac2023-03-30 20:20:02 +0800
commit424da107462c3dee3a02285f8d222c5e9a678855 (patch)
tree4019fa73b7b4885503f307c8416e30357f441f19 /PKGBUILD
parent896be62ce3823e7da6d1306008d9dad0bacfffa1 (diff)
downloadaur-424da107462c3dee3a02285f8d222c5e9a678855.tar.gz
[lilac] updated to 0.2.12-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a4417ae37da..01b90f044379 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,35 @@
_pkgname=Augmentor
pkgname=python-augmentor
pkgver=0.2.12
-pkgrel=1
+pkgrel=2
pkgdesc='Image augmentation library in Python for machine learning'
arch=(any)
url=https://github.com/mdbloice/Augmentor
license=(MIT)
-depends=(python-future python-numpy python-pillow python-tqdm)
-makedepends=(python-setuptools)
+depends=(
+ python-numpy
+ python-pandas
+ python-pillow
+ python-tqdm
+)
+makedepends=(
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
+)
checkdepends=(python-pytest)
source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/mdbloice/Augmentor/archive/${pkgver}.tar.gz")
sha512sums=('27a37d52cbf51dcb2bb8c7c5d74efbe2d2cb066b9ed958b3a84456d524fff82dd19e9da1ab23064490171d078ebd764e900fc39d8fb4e4bd1e23b13e0589cb85')
+prepare() {
+ # fix https://github.com/mdbloice/Augmentor/issues/218
+ sed -i "s,cat_col_series.get_values,cat_col_series.to_numpy," "${_pkgname}-${pkgver}/Augmentor/ImageUtilities.py"
+}
+
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -26,7 +41,7 @@ check() {
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: