summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-15 10:37:40 -0400
committerGuillaume Horel2017-07-15 10:37:40 -0400
commit8da603c76048fa3b248a0288abddabea31c2616b (patch)
tree553f7e1eda12b85d8189c26eb434b6916bd3c887 /PKGBUILD
downloadaur-8da603c76048fa3b248a0288abddabea31c2616b.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02a2fa3bb2a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-autograd')
+_pkgname='autograd'
+pkgver='1.1.11'
+pkgrel=1
+pkgdesc="Efficiently computes derivatives of numpy code"
+url="https://github.com/HIPS/autograd"
+depends=('python'
+ 'python-numpy'
+ 'python-scipy')
+checkdepends=()
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('6a50cc28a17a1411b8e817b9c1e171e6d7a9b3fef1568622f87fe184c471b14c')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+