summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2020-12-19 20:05:07 +0100
committerKokaKiwi2020-12-19 20:05:34 +0100
commit2014689995f5b944a51ac5a4d69fbfc2243355a1 (patch)
tree66465151fe487bc2f3e40b781715c63bd180ee4b /PKGBUILD
downloadaur-python-autokernel-git.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3711579e3837
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+_pkgname=autokernel
+pkgname="python-${_pkgname}-git"
+pkgver=v0.9.6.r0.g43bbe35
+pkgrel=1
+pkgdesc="A tool to autodetect and manage kernel configuration options"
+arch=('any')
+url="https://autokernel.oddlama.org/"
+license=('MIT')
+depends=('python'
+ 'python-kconfiglib' 'python-lark-parser' 'python-dateutil'
+ 'python-requests' 'python-sympy')
+makedepends=('python-setuptools')
+source=("${pkgname}::git+https://github.com/oddlama/autokernel.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}