summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Gizdov2018-10-14 12:59:49 +0100
committerKonstantin Gizdov2018-10-14 12:59:49 +0100
commit6270a189d8bdf676740c64834567740f8a0e65c7 (patch)
tree688d95a48e3dd0b832569ac45987c580dbadbe23 /PKGBUILD
parent59bfa242560e113a39bd630d20d21eee45954dd7 (diff)
downloadaur-6270a189d8bdf676740c64834567740f8a0e65c7.tar.gz
fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 020a20b3d1dd..f45ac59c6c71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,8 @@ pkgver=0.0.9
pkgrel=1
pkgdesc="Manipulate jagged, chunky, and/or bitmasked arrays as easily as Numpy"
arch=('any')
+makedepends=('python2-setuptools' 'python2-numpy'
+ 'python-setuptools' 'python-numpy')
url="https://github.com/scikit-hep/awkward-array"
license=('BSD')
options=(!emptydirs)
@@ -27,22 +29,16 @@ prepare() {
-i '{}' \; -print
}
-build_python2-awkward-array() {
- makedepends=('python2-setuptools' 'python2-numpy')
+build() {
+ msg2 "Building Python3"
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+ python setup.py build
msg2 "Building Python2"
cd "${srcdir}/${_pkgbase}-py2-${pkgver}"
python2 setup.py build
}
-build_python-awkward-array() {
- makedepends=('python-setuptools' 'python-numpy')
-
- msg2 "Building Python3"
- cd "${srcdir}/${_pkgbase}-${pkgver}"
- python setup.py build
-}
-
package_python2-awkward-array() {
depends=('python2-numpy')
optdepends=('python2-arrow: interoperability with other applications and fast Parquet reading/writing'