summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Javorski2024-05-11 13:53:51 -0700
committerMike Javorski2024-05-11 17:37:37 -0700
commitddf2ac23fd80d643883d7bf7258679e5f4f4251f (patch)
treeba3fa62a04976d4343868c22ada75bdb42737939 /PKGBUILD
parent770b5ce31c0e9e6ecb9f128d4a099e4e5fad6780 (diff)
downloadaur-ddf2ac23fd80d643883d7bf7258679e5f4f4251f.tar.gz
Switch to PEP517
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3b995470278..f5433579d5a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,17 @@ license=('Apache')
replaces=('python-aws_lambda_builders')
conflicts=('python-aws_lambda_builders')
depends=('python-six' 'python-wheel')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
options=(!emptydirs)
source=("https://github.com/aws/${_name}/archive/v$pkgver/${_name}-$pkgver.tar.gz")
sha256sums=('d5973584a6e0575f6f8fa9723d9d051c51547eec77217ca1f0d77224ef55f866')
+build() {
+ cd $_name-$pkgver
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_name-$pkgver"
- /usr/bin/python setup.py install --root="$pkgdir/" --optimize=1
+ cd $_name-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
}