summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 20:48:12 -0700
committerKelsey Maes2017-03-19 20:48:12 -0700
commit4f3a33cee5f9e4f3518f9448d54437b94e43c5c8 (patch)
treea58e4281e99f81515f99f7065ebf37fef0bc6684 /PKGBUILD
downloadaur-4f3a33cee5f9e4f3518f9448d54437b94e43c5c8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fddf645ba071
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-acs
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools ACS Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core' 'python-azure' 'python-scp' 'python-sshtunnel')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('5376d7d42e390bd267050b2339cf859d')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+} \ No newline at end of file