summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 21:00:50 -0700
committerKelsey Maes2017-03-19 21:00:50 -0700
commit0921a91d8902b61b5cf62dd16b58234296b59d31 (patch)
tree41f0bcacc4dca30bf8eb770a9f166a4cd78fe7fc /PKGBUILD
downloadaur-0921a91d8902b61b5cf62dd16b58234296b59d31.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d51751b63ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-network
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools Network Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure' 'python-azure-cli-core')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('1475432a6613141c1813347b29b07318')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}