summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:47:12 -0700
committerKelsey Maes2017-05-01 22:47:12 -0700
commit331ddfac6f1413761e00a98bfe477e5a99fea5dd (patch)
tree56a0d872a5222cdd72a07ad017e3881420a57b05 /PKGBUILD
parent0921a91d8902b61b5cf62dd16b58234296b59d31 (diff)
downloadaur-331ddfac6f1413761e00a98bfe477e5a99fea5dd.tar.gz
2.0.4 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d51751b63ba..958866869af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-network
pkgname=python-$_name
-pkgver=2.0.1
+pkgver=2.0.4
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools Network Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure' 'python-azure-cli-core')
+depends=('python-azure' 'python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('1475432a6613141c1813347b29b07318')
+md5sums=('2975dba763f69579d6a508251f9b4dae')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}