summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpallxk2019-06-21 14:28:45 +0800
committerpallxk2019-06-21 14:28:45 +0800
commit0ce0d6c96f07579ed499c02c86f2729027c7f5b1 (patch)
treeb70807e648c567d366a8cbf9c632d91c7024b683 /PKGBUILD
parent3835027629c49c787014283f51993ffcdd5c6be3 (diff)
downloadaur-0ce0d6c96f07579ed499c02c86f2729027c7f5b1.tar.gz
Add appropriate auto version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2630ef5d6805..fa802b1cf6ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: pallxk <aur at pallxk dot com>
pkgname=python-azure-git
-pkgver=latest
-pkgrel=2
+pkgver=4.0.0.r720.gff6fd86c4
+pkgrel=1
pkgdesc="Microsoft Azure SDK for Python"
arch=('any')
url="https://github.com/Azure/azure-sdk-for-python"
@@ -14,6 +14,11 @@ conflicts=('python-azure')
source=("git+https://github.com/Azure/azure-sdk-for-python.git")
md5sums=('SKIP')
+pkgver() {
+ cd azure-sdk-for-python
+ git describe --long --tags --match azure_* | sed 's/^azure_//;s/-/.r/;s/-/./'
+}
+
build() {
cd azure-sdk-for-python
python setup.py build